<!DOCTYPE html><!-- HTML 5 -->
<html lang="en-US">

<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<title>Filing open in 2020 school board election | The Electric</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://theelectricgf.com/xmlrpc.php" />

<!--[if lt IE 9]>
<script src="https://theelectricgf.com/wp-content/themes/dynamic-news/js/html5shiv.js" type="text/javascript"></script>
<![endif]-->
<script type="text/javascript">
  WebFontConfig = {"typekit":{"id":"tpg6ogr"}};
  (function() {
    var wf = document.createElement('script');
    wf.src = 'https://theelectricgf.com/wp-content/mu-plugins/wpcomsh/vendor/automattic/custom-fonts/js/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
	})();
</script><style id="jetpack-custom-fonts-css">.wf-active #logo .site-title{font-weight:500;font-family:"sorts-mill-goudy-1","sorts-mill-goudy-2",serif;font-style:normal}.wf-active #header-content #header-text{font-style:normal;font-weight:500}.wf-active .widgettitle{font-family:"sorts-mill-goudy-1","sorts-mill-goudy-2",serif;font-style:normal;font-weight:500}.wf-active .page-title, .wf-active .post-title{font-weight:500;font-family:"sorts-mill-goudy-1","sorts-mill-goudy-2",serif;font-style:normal}.wf-active .page-title{font-style:normal;font-weight:500}.wf-active .post-title{font-style:normal;font-weight:500}.wf-active .archive-title{font-weight:500;font-style:normal}.wf-active .comment h1, .wf-active .comment h2, .wf-active .comment h3, .wf-active .comment h4, .wf-active .comment h5, .wf-active .comment h6, .wf-active .entry h1, .wf-active .entry h2, .wf-active .entry h3, .wf-active .entry h4, .wf-active .entry h5, .wf-active .entry h6{font-weight:500;font-style:normal}.wf-active #comments .comments-title, .wf-active #respond #reply-title{font-weight:500;font-family:"sorts-mill-goudy-1","sorts-mill-goudy-2",serif;font-style:normal}.wf-active .widget-category-posts .type-post .post-title{font-style:normal;font-weight:500}.wf-active .widget-category-posts .more-posts .post-title{font-family:"sorts-mill-goudy-1","sorts-mill-goudy-2",serif;font-style:normal;font-weight:500}</style>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Electric &raquo; Feed" href="https://theelectricgf.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Electric &raquo; Comments Feed" href="https://theelectricgf.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Electric &raquo; Filing open in 2020 school board election Comments Feed" href="https://theelectricgf.com/2019/12/18/filing-open-in-2020-school-board-election/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.10.1 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.10.1';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-97815357-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-97815357-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/theelectricgf.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='dynamicnews-stylesheet-css'  href='https://theelectricgf.com/wp-content/themes/dynamic-news/style.css?ver=20140326' type='text/css' media='all' />
<link rel='stylesheet' id='dynamicnews-genericons-css'  href='https://theelectricgf.com/wp-content/themes/dynamic-news/css/genericons/genericons.css?ver=20150106' type='text/css' media='all' />
<link rel='stylesheet' id='dynamicnews-flexslider-css'  href='https://theelectricgf.com/wp-content/themes/dynamic-news/css/flexslider.css?ver=20140228' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='dynamicnews-droid-sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3A400&#038;ver=5.3.2' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='dynamicnews-francois-one-css'  href='https://fonts.googleapis.com/css?family=Francois+One%3A400&#038;ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/8.0/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.0/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/theelectricgf.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://theelectricgf.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.10.1'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://theelectricgf.com/wp-content/themes/dynamic-news/js/jquery.flexslider.js?ver=20141023'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var DynamicNewsSliderParams = {"animation":"horizontal","speed":"7000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://theelectricgf.com/wp-content/themes/dynamic-news/js/slider.js?ver=20141022'></script>
<script type='text/javascript' src='https://theelectricgf.com/wp-content/themes/dynamic-news/js/navigation.js?ver=20141022'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/postmessage.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/jquery.jetpack-resize.min.js'></script>
<link rel='https://api.w.org/' href='https://theelectricgf.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://theelectricgf.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://theelectricgf.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Commission approves contract for fire station sewer repairs' href='https://theelectricgf.com/2019/12/18/commission-approves-contract-for-fire-station-sewer-repairs/' />
<link rel='next' title='State begins enforcing emergency rules banning sale of flavored e-cigarettes' href='https://theelectricgf.com/2019/12/18/state-begins-enforcing-emergency-rules-banning-sale-of-flavored-e-cigarettes/' />

<link rel="canonical" href="https://theelectricgf.com/2019/12/18/filing-open-in-2020-school-board-election/" />
<link rel='shortlink' href='https://wp.me/p8BbsL-5fI' />
<link rel="alternate" type="application/json+oembed" href="https://theelectricgf.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheelectricgf.com%2F2019%2F12%2F18%2Ffiling-open-in-2020-school-board-election%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://theelectricgf.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheelectricgf.com%2F2019%2F12%2F18%2Ffiling-open-in-2020-school-board-election%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.2.1 Professional to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-3 { margin:15px 15px 15px 15px; float:right; clear:right; }
	.g-3 { margin:15px 15px 15px 15px; float:right; clear:right; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->


<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">
			@media only screen and (min-width: 60em) {
				#wrapper {
					margin: 0;
					width: 100%;
					max-width: 100%;
					background: none;
				}
				#header {
					padding: 3em 0.5em;
				}
				.container {
					max-width: 1340px;
					width: 92%;
					margin: 0 auto;
					-webkit-box-sizing: border-box;
					-moz-box-sizing: border-box;
					box-sizing: border-box;
				}
				#wrap {
					padding: 1.5em 0;
				}
			}
			@media only screen and (max-width: 70em) {
				.container {
					width: 94%;
				}
			}
			@media only screen and (max-width: 65em) {
				.container {
					width: 96%;
				}
				#wrapper {
					background: #fff;
				}
			}
			@media only screen and (max-width: 60em) {
				.container {
					width: 100%;
					margin: 0;
					-webkit-box-sizing: border-box;
					-moz-box-sizing: border-box;
					box-sizing: border-box;
				}
				#wrap {
					padding: 1.5em 1.5em 0;
				}
			}
		</style><meta name="description" content="Filing opened last week for three seats on the Great Falls Public Schools board. Each of those are three-year terms. Those seats are currently held by Jason Brantley, Jan Cahill and Kim Skornogoski. Filing is open through March 26 and the election is scheduled for May 5, 2020. Three candidates file for three GFPS board&hellip;" />
<link rel="amphtml" href="https://theelectricgf.com/2019/12/18/filing-open-in-2020-school-board-election/amp/">
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Filing open in 2020 school board election" />
<meta property="og:url" content="https://theelectricgf.com/2019/12/18/filing-open-in-2020-school-board-election/" />
<meta property="og:description" content="Filing opened last week for three seats on the Great Falls Public Schools board. Each of those are three-year terms. Those seats are currently held by Jason Brantley, Jan Cahill and Kim Skornogoski…" />
<meta property="article:published_time" content="2019-12-19T03:37:31+00:00" />
<meta property="article:modified_time" content="2019-12-19T03:37:31+00:00" />
<meta property="og:site_name" content="The Electric" />
<meta property="og:image" content="https://i1.wp.com/theelectricgf.com/wp-content/uploads/2017/06/20170616_1549491.jpg?fit=1200%2C900&amp;ssl=1" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="900" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Filing open in 2020 school board election" />
<meta name="twitter:image" content="https://i1.wp.com/theelectricgf.com/wp-content/uploads/2017/06/20170616_1549491.jpg?fit=1200%2C900&#038;ssl=1&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<style type="text/css" id="custom-colors-css">input[type=submit],#mainnav-menu a:hover,#mainnav-menu ul a:hover,.widget-tabnav li a,.postinfo .meta-category a:hover,.postinfo .meta-category a:active,.more-link span,.read-more,#social-icons-menu li a,.bypostauthor .fn,.comment-author-admin .fn,#commentform #submit,#mainnav-icon:hover,#frontpage-slider-wrap:hover .frontpage-slider-controls a:hover,#social-icons-menu li a:before,.widget-tabnav li a:link,.widget-tabnav li a:visited,.more-link:link,.more-link:visited{color:#fff}#navi-wrap,#mainnav-menu a:link,#mainnav-menu a:visited,.widgettitle,.postinfo .meta-category a,#social-icons-menu li a:hover,#footer-widgets .widgettitle,#footer-widgets .widget ul,#footer-widgets .widget div,#footer-wrap,#frontpage-slider .zeeslide .slide-entry,.frontpage-slider-controls .zeeflex-direction-nav a:before,#frontpage-slider .zeeslide .slide-title a:link,#frontpage-slider .zeeslide .slide-title a:visited,#footer a:hover,.widget-tabnavi li a:hover,.widget-tabnavi li a:active,#frontpage-slider .zeeslide .slide-more-link,#frontpage-slider .zeeslide .slide-more-link:link,#frontpage-slider .zeeslide .slide-more-link:visited{color:#fff}#footer-widgets .widget a:link,#footer-widgets .widget a:visited,#frontpage-slider .zeeslide .slide-title a:hover,#frontpage-slider .zeeslide .slide-title a:active{color:#ccc}.postmeta,#footer-widgets .widget-tabnav li a{color:#a3a3a3}code,pre,.comment-author .comment-meta{color:#a3a3a3}#frontpage-slider .zeeslide .slide-title{border-color:#ddd}#footer a{color:#a3a3a3}body{background:#e5e5e5}a,a:link,a:visited,#logo .site-title,.widget a:link,.widget a:visited,#flickr_badge_uber_wrapper a:link,#flickr_badge_uber_wrapper a:visited,#flickr_badge_uber_wrapper a:hover,#flickr_badge_uber_wrapper a:active,.post-title a:hover,.post-title a:active,.infinite-scroll #infinite-handle span,#image-nav .nav-previous a,#image-nav .nav-next a{color:#1562a5}input[type=submit],#mainnav-menu a:hover,#mainnav-menu ul a:hover,.postinfo .meta-category a:hover,.postinfo .meta-category a:active,#social-icons-menu li a,.bypostauthor .fn,.comment-author-admin .fn,#commentform #submit,#mainnav-icon:hover,.frontpage-slider-controls .zeeflex-control-paging li a.zeeflex-active{background:#1562a5}.widget-tabnav li a,.more-link span,.read-more,#frontpage-slider-wrap:hover .frontpage-slider-controls a:hover,.more-link{background-color:#1562a5}.archive-title span{color:#60aaeb}#frontpage-slider .zeeslide .slide-entry{border-top-color:#1562a5}#logo a:hover .site-title,#logo .site-description,#mainnav-menu ul a,.search-form .search-field,.search-form .search-submit:hover .genericon-search,#wp-calendar tbody #today,.page-title,.post-title,.post-title a:link,.post-title a:visited,.postmeta,.postinfo .meta-category,.archive-title,.post-pagination,.infinite-scroll #infinite-handle span:hover,#image-nav,#comments .comments-title,#respond #reply-title{color:#333}#navi-wrap,.widgettitle,.postinfo .meta-category a,.comment-author .fn,#footer-widgets-bg,#footer-wrap,#frontpage-slider .zeeslide .slide-entry,.frontpage-slider-controls .zeeflex-direction-nav a,#social-icons-menu li a:hover,.widget-tabnavi li a:hover,.widget-tabnavi li a:active{background:#333}.page-title,.post-title,#comments .comments-title,#respond #reply-title{border-bottom-color:#333}#footer-widgets .widget-tabnav li a{color:#333}.postmeta,code,pre,.comment-author,.comment-pagination,.widget-category-posts .more-posts .type-post,#widget-category-posts-columns .category-posts-columns .more-posts .type-post,#footer-widgets .widget-tabnav li a{background:#333}.postmeta,code,pre,.comment-author,.comment-pagination,.widget-category-posts .more-posts .type-post,#widget-category-posts-columns .category-posts-columns .more-posts .type-post,#footer-widgets .widget-tabnav li a{background:rgba(51,51,51,.1)}#footer-widgets .widgettitle{background:#545454}#footer-widgets .widget{background:#3f3f3f}#header-content #header-text{color:#6d6d6d}</style>
<link rel="icon" href="https://i2.wp.com/theelectricgf.com/wp-content/uploads/2018/03/electric_logo-1-e1520726324675.jpg?fit=32%2C27&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i2.wp.com/theelectricgf.com/wp-content/uploads/2018/03/electric_logo-1-e1520726324675.jpg?fit=192%2C160&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i2.wp.com/theelectricgf.com/wp-content/uploads/2018/03/electric_logo-1-e1520726324675.jpg?fit=180%2C150&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i2.wp.com/theelectricgf.com/wp-content/uploads/2018/03/electric_logo-1-e1520726324675.jpg?fit=270%2C225&#038;ssl=1" />
			<style type="text/css" id="wp-custom-css">
				/*
Welcome to Custom CSS!

To learn how this works, see http://wp.me/PEmnE-Bt
*/
(function(i,s,o,g,r,a,m) {
}	
}			</style>
		</head>

<body class="post-template-default single single-post postid-20194 single-format-standard custom-colors">

<div id="wrapper" class="hfeed">

	<div id="header-wrap">

		<header id="header" class="container clearfix" role="banner">

			<div id="logo">

				<a href="https://theelectricgf.com/" title="The Electric" rel="home">
								<img class="logo-image" src="https://theelectricgf.com/wp-content/uploads/2019/07/Header-image.jpg" alt="Logo" /></a>
							</a>

			
			</div>

			<div id="header-content" class="clearfix">
							</div>

		</header>

	</div>

	<div id="navi-wrap">
		<nav id="mainnav" class="container clearfix" role="navigation">
			<h3 id="mainnav-icon">Menu</h3>
			<ul id="mainnav-menu" class="menu"><li id="menu-item-18" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18"><a href="/">Home</a></li>
<li id="menu-item-19" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19"><a href="https://theelectricgf.com/about/">About</a></li>
<li id="menu-item-12728" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12728"><a href="https://theelectricgf.com/contribute/">Contribute/Advertise</a></li>
</ul>		</nav>
	</div>

	
	<div id="wrap" class="container clearfix">

		<section id="content" class="primary" role="main">

		
	<article id="post-20194" class="post-20194 post type-post status-publish format-standard has-post-thumbnail hentry category-cascade-county category-education category-elections category-great-falls">

		<h2 class="post-title">Filing open in 2020 school board election</h2>

		<div class="postmeta">
		<span class="meta-date">
		Posted on <a href="https://theelectricgf.com/2019/12/18/filing-open-in-2020-school-board-election/" title="8:37 pm" rel="bookmark"><time datetime="2019-12-18T20:37:31-07:00">December 18, 2019</time></a>		</span>

		<span class="meta-author sep">
		by <a href="https://theelectricgf.com/author/jenn8302/" title="View all posts by Jenn Rowell" rel="author">Jenn Rowell</a>		</span>

		</div>

		<img width="860" height="280" src="https://i1.wp.com/theelectricgf.com/wp-content/uploads/2017/06/20170616_1549491.jpg?resize=860%2C280&amp;ssl=1" class="attachment-featured_image size-featured_image wp-post-image" alt="" data-attachment-id="1921" data-permalink="https://theelectricgf.com/20170616_154949-2/" data-orig-file="https://i1.wp.com/theelectricgf.com/wp-content/uploads/2017/06/20170616_1549491.jpg?fit=4032%2C3024&amp;ssl=1" data-orig-size="4032,3024" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;1.7&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;SM-G930V&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1497628189&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;4.2&quot;,&quot;iso&quot;:&quot;40&quot;,&quot;shutter_speed&quot;:&quot;0.0006544502617801&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Cascade County Elections Office" data-image-description="" data-medium-file="https://i1.wp.com/theelectricgf.com/wp-content/uploads/2017/06/20170616_1549491.jpg?fit=300%2C225&amp;ssl=1" data-large-file="https://i1.wp.com/theelectricgf.com/wp-content/uploads/2017/06/20170616_1549491.jpg?fit=860%2C645&amp;ssl=1" />
		<div class="entry clearfix">
			<div class="g g-3"><div class="g-single a-80"><a class="gofollow" data-track="ODAsMywxLDYw" href="https://flygtf.com/low-fares/" target="_blank" rel="nofollow"><img src="https://i0.wp.com/theelectricgf.com/wp-content/banners/electricad.11192019-resized.jpg?ssl=1" width="300" height="252" srcset="https://theelectricgf.com/wp-content/banners/electricad.11192019-resized.jpg 300w" sizes="1281px" /></a></div></div><p>Filing opened last week for three seats on the Great Falls Public Schools board.</p>
<p>Each of those are three-year terms.</p>
<p>Those seats are currently held by Jason Brantley, Jan Cahill and Kim Skornogoski.</p>
<p>Filing is open through March 26 and the election is scheduled for May 5, 2020.</p>
<p><span style="color: #3366ff;"><a style="color: #3366ff;" href="https://theelectricgf.com/2019/04/02/three-candidates-file-for-three-gfps-board-seats-no-election-in-may/" target="_blank" rel="noopener noreferrer">Three candidates file for three GFPS board seats; no election in May</a></span></p>
<p>Anyone interested in running must file a declaration of intent and oath of candidacy with the Cascade County Elections Office at 325 2nd Ave. N.</p>
<p>Candidates must report campaign expenditures to the Montana Commissioner of Political Practices.</p>
<p>This year, three school board seats were open and only three people filed so those candidates won by acclamation and there was no election.</p>
<p>&nbsp;</p>
<div class="g g-5"><div class="g-single a-79"><a class="gofollow" data-track="NzksNSwxLDYw" href="https://bighornoutdoorspecialists.com/" target="_blank" rel="nofollow"><img src="https://i2.wp.com/theelectricgf.com/wp-content/banners/you-should-be-outside-winter-1.png?ssl=1" width="728" height="90" srcset="https://theelectricgf.com/wp-content/banners/you-should-be-outside-winter-1.png 728w" sizes="1281px" /></a></div></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-20194" class="share-twitter sd-button share-icon" href="https://theelectricgf.com/2019/12/18/filing-open-in-2020-school-board-election/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-20194" class="share-facebook sd-button share-icon" href="https://theelectricgf.com/2019/12/18/filing-open-in-2020-school-board-election/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-127072891-20194-5dfbafb9d565b' data-src='https://widgets.wp.com/likes/#blog_id=127072891&amp;post_id=20194&amp;origin=theelectricgf.com&amp;obj_id=127072891-20194-5dfbafb9d565b' data-name='like-post-frame-127072891-20194-5dfbafb9d565b'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>			<!-- <rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="https://theelectricgf.com/2019/12/18/filing-open-in-2020-school-board-election/"
    dc:identifier="https://theelectricgf.com/2019/12/18/filing-open-in-2020-school-board-election/"
    dc:title="Filing open in 2020 school board election"
    trackback:ping="https://theelectricgf.com/2019/12/18/filing-open-in-2020-school-board-election/trackback/" />
</rdf:RDF> -->
			<div class="page-links"></div>
		</div>

		<div class="postinfo clearfix">
		<span class="meta-category">
			<ul class="post-categories">
	<li><a href="https://theelectricgf.com/category/cascade-county/" rel="category tag">Cascade County</a></li>
	<li><a href="https://theelectricgf.com/category/education/" rel="category tag">Education</a></li>
	<li><a href="https://theelectricgf.com/category/elections/" rel="category tag">Elections</a></li>
	<li><a href="https://theelectricgf.com/category/great-falls/" rel="category tag">Great Falls</a></li></ul>		</span>

	</div>

	</article>
		


		</section>

		<section id="sidebar" class="secondary clearfix" role="complementary">

	<aside id="ajdg_grpwidgets-3" class="widget ajdg_grpwidgets"><div class="g g-4"><div class="g-single a-55"><a class="gofollow" data-track="NTUsNCwxLDYw" href="https://www.ozogeye.com" target="_blank" rel="nofollow"><img src="https://i0.wp.com/theelectricgf.com/wp-content/banners/ozog-eye-care-fp.jpg?ssl=1" width="360" height="576" srcset="https://theelectricgf.com/wp-content/banners/ozog-eye-care-fp.jpg 360w" sizes="1281px" /></a></div></div></aside><aside id="categories-3" class="widget widget_categories"><h3 class="widgettitle">News Categories</h3><form action="https://theelectricgf.com" method="get"><label class="screen-reader-text" for="cat">News Categories</label><select  name='cat' id='cat' class='postform' >
	<option value='-1'>Select Category</option>
	<option class="level-0" value="14572">Agriculture</option>
	<option class="level-0" value="336053407">Arts and Culture</option>
	<option class="level-0" value="17076394">Cascade County</option>
	<option class="level-0" value="1523438">City Budget</option>
	<option class="level-0" value="1562321">City Commission</option>
	<option class="level-0" value="77994096">City of Great Falls</option>
	<option class="level-0" value="3897">Economic Development</option>
	<option class="level-0" value="1342">Education</option>
	<option class="level-0" value="31174">Elections</option>
	<option class="level-0" value="240757">Food and Agriculture</option>
	<option class="level-0" value="1322995">Great Falls</option>
	<option class="level-0" value="12272452">Great Falls Public Library</option>
	<option class="level-0" value="336053411">Great Falls Public Schools</option>
	<option class="level-0" value="337">Health</option>
	<option class="level-0" value="299">Housing</option>
	<option class="level-0" value="9890171">Intercontinental Ballistic Missiles</option>
	<option class="level-0" value="336053408">Legislature</option>
	<option class="level-0" value="336053412">Library</option>
	<option class="level-0" value="336053403">Malmstrom Air Force Base</option>
	<option class="level-0" value="5004">Mental Health</option>
	<option class="level-0" value="488">Military</option>
	<option class="level-0" value="3837">Montana</option>
	<option class="level-0" value="44201558">Montana Air National Guard</option>
	<option class="level-0" value="523970">Park and Rec</option>
	<option class="level-0" value="10363">Parking</option>
	<option class="level-0" value="3902">Public Safety</option>
	<option class="level-0" value="336053415">Recreation</option>
	<option class="level-0" value="2401">Transportation</option>
	<option class="level-0" value="1">Uncategorized</option>
	<option class="level-0" value="10266">Utilities</option>
	<option class="level-0" value="69471">Veterans</option>
	<option class="level-0" value="336053414">Weather</option>
</select>
</form>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>

			</aside><aside id="search-3" class="widget widget_search">
	<form role="search" method="get" class="search-form" action="https://theelectricgf.com/">
		<label>
			<span class="screen-reader-text">Search for:</span>
			<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s">
		</label>
		<button type="submit" class="search-submit">
			<span class="genericon-search"></span>
		</button>
	</form>

</aside><aside id="dynamicnews_social_icons-3" class="widget dynamicnews_social_icons"><h3 class="widgettitle">Follow Us for Mo&#039; News</h3>		<div id="widget-social-icons" class="social-icons-wrap clearfix">

			<ul id="social-icons-menu" class="menu"><li id="menu-item-21" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21"><a href="https://www.facebook.com/TheElectricGF/"><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-14083" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14083"><a href="http://instagram.com/the_electric_gf"><span class="screen-reader-text">Instagram</span></a></li>
<li id="menu-item-23" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23"><a href="http://www.twitter.com/theelectricgf"><span class="screen-reader-text">Twitter</span></a></li>
</ul>
		</div>
	</aside><aside id="custom_html-5" class="widget_text widget widget_custom_html"><h3 class="widgettitle">Support The Electric</h3><div class="textwidget custom-html-widget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top">
<input type="hidden" name="cmd" value="_s-xclick">
<input type="hidden" name="hosted_button_id" value="GQVFVZBYKVKFU">
<table>
<tr><td><input type="hidden" name="on0" value=""></td></tr><tr><td><select name="os0">
	<option value="Option 1">Option 1 : $5.00 USD - monthly</option>
	<option value="Option 2">Option 2 : $10.00 USD - monthly</option>
	<option value="Option 3">Option 3 : $25.00 USD - monthly</option>
	<option value="Option 4">Option 4 : $50.00 USD - monthly</option>
</select> </td></tr>
</table>
<input type="hidden" name="currency_code" value="USD">
<input type="image" src="https://www.paypalobjects.com/en_US/i/btn/btn_subscribeCC_LG.gif" border="0" name="submit" alt="PayPal - The safer, easier way to pay online!">
<img alt="" border="0" src="https://www.paypalobjects.com/en_US/i/scr/pixel.gif" width="1" height="1">
</form>
</div></aside><aside id="custom_html-7" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://theelectricgf.us17.list-manage.com/subscribe/post?u=47b27c9b1e4f4f30c99090271&amp;id=76f0623c40" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	<label for="mce-EMAIL">Subscribe to our mailing list</label>
	<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_47b27c9b1e4f4f30c99090271_76f0623c40" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>

<!--End mc_embed_signup--></div></aside><aside id="rss_links-3" class="widget widget_rss_links"><h3 class="widgettitle">The latest from The Electric</h3><ul><li><a target="_self" href="https://theelectricgf.com/feed/" title="Subscribe to Posts">RSS - Posts</a></li></ul>
</aside>
</section>
	</div>


	<div id="footer-widgets-bg">

		<div id="footer-widgets-wrap" class="container">

			<div id="footer-widgets" class="clearfix">

				<div class="footer-widget-column">
					<aside id="custom_html-9" class="widget_text widget widget_custom_html"><h3 class="widgettitle">Support The Electric</h3><div class="textwidget custom-html-widget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top">
<input type="hidden" name="cmd" value="_s-xclick">
<input type="hidden" name="hosted_button_id" value="GQVFVZBYKVKFU">
<table>
<tr><td><input type="hidden" name="on0" value=""></td></tr><tr><td><select name="os0">
	<option value="Option 1">Option 1 : $5.00 USD - monthly</option>
	<option value="Option 2">Option 2 : $10.00 USD - monthly</option>
	<option value="Option 3">Option 3 : $25.00 USD - monthly</option>
	<option value="Option 4">Option 4 : $50.00 USD - monthly</option>
</select> </td></tr>
</table>
<input type="hidden" name="currency_code" value="USD">
<input type="image" src="https://www.paypalobjects.com/en_US/i/btn/btn_subscribeCC_LG.gif" border="0" name="submit" alt="PayPal - The safer, easier way to pay online!">
<img alt="" border="0" src="https://www.paypalobjects.com/en_US/i/scr/pixel.gif" width="1" height="1">
</form>
</div></aside>				</div>
				<div class="footer-widget-column">
									</div>
				<div class="footer-widget-column">
									</div>
				<div class="footer-widget-column">
					<aside id="custom_html-10" class="widget_text widget widget_custom_html"><h3 class="widgettitle">Subscribe The Electric&#8217;s updates</h3><div class="textwidget custom-html-widget"><!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://theelectricgf.us17.list-manage.com/subscribe/post?u=47b27c9b1e4f4f30c99090271&amp;id=76f0623c40" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	<label for="mce-EMAIL">Subscribe to our mailing list</label>
	<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_47b27c9b1e4f4f30c99090271_76f0623c40" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>

<!--End mc_embed_signup--></div></aside>				</div>

			</div>

		</div>

	</div>


		<div id="footer-wrap">

			<footer id="footer" class="container clearfix" role="contentinfo">
				<div id="credit-link">
					<a></a> 
									</div>
			</footer>

		</div>

</div><!-- end #wrapper -->

<!--  -->
<!-- Jetpack Google Analytics -->
			<script type='text/javascript'>
				var _gaq = _gaq || [];
				_gaq.push(['_setAccount', 'UA-108829537-1']);
_gaq.push(['_trackPageview']);
				(function() {
					var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
					ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
	<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/theelectricgf.com\/2019\/12\/18\/filing-open-in-2020-school-board-election\/":20194};
	</script>
				<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/theelectricgf.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://theelectricgf.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201951'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2019Decaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/modules/wpgroho.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/likes/queuehandler.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=201951#ver=201951' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	<script type='text/javascript' src='https://stats.wp.com/e-201951.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.0',blog:'127072891',post:'20194',tz:'-7',srv:'theelectricgf.com'} ]);
	_stq.push([ 'clickTrackerInit', '127072891', '20194' ]);
</script>
</body>
</html>